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1 Introduction

The Epygi Auto Dialer (herein Auto Dialer) is a PC-based application designed to work with Epygi IP PBXs. Auto
Dialer will call via Epygi IP PBXs to the predefined numbers with the option of playing audio messages and the
audio menu upon answering the call. Outbound calls can be activated manually or based on schedule, audio
messages and audio menu played to called destination can be pre-recorded and updated regularly. The Auto
Dialer application will prompt the called party to enter a response by pressing one or more DTMF keys to
navigate through menus. Then the entered responses will be updated in the calling list.

The described below mainly concern the Epygi IP PBXs of QX line (herein QX). In general, Auto Dialer can be
configured and used identically with Epygi IP PBXs of QX and Quadro line.

This guide provides a general description on how to configure and use Auto Dialer with the QX. A Doctor Office
example is provided to show the implementation and usage of Auto Dialer.

2 Target Market

The Auto Dialer’s target industry are small doctors’ offices, independent pharmacies, schools and other service
providers that call their customers on a daily basis as part of their operating procedures. Some of the usage
scenarios are as follows:

e Schools/colleges — a school management calls parents on a weekly basis to inform about
appointments, study progress, current marks, absences and etc. Teachers do this manually by using
the front office staff to place the calls. Many times, they have to call more than once if there is no
answer, voice mail is encountered or the wrong person answers.

o Marketing offices — the marketing team calls people on a daily, weekly or monthly basis for marketing
research. Researchers do this manually by using the front office staff to place the calls. For example,
researcher could create scenario (query), which would allow evaluating services, etc.

e Doctor offices — the doctor’s office calls their patients on a daily basis to confirm appointments for the
week and to minimize no—show appointments, which cost the doctor time and money. Doctors do this
manually by using the front office staff to place the calls. Many times, they have to call more than once if
there is no answer, voice mail is encountered or the wrong person answers. In some cases, the patient
needs to reschedule their appointment time and contact the doctor’s office directly.

e Small local pharmacies — large pharmacy chains have very expensive phone systems, tied to their ERP
systems that perform automated calling to alert patients when their prescriptions are ready. These
systems also allow patients to call into the IVR and automatically refill prescriptions by entering their
specific prescription number using the phone keypad. These systems are not always affordable,
especially for small, independent pharmacies which have to rely on staff for customer calls notifying
them when prescriptions are filled and ready to be picked up.

o Telemarketing — Telemarketers prepare recorded promotions based on a customer database and place
calls to the selected customers which allow them to talk to an agent or opt out.
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3 Requirements

3.1 System Requirements

One of the mentioned operating systems should run on the PC for proper operation of Auto Dialer:

e Windows 10, Windows 8.1, Windows 7, Windows Vista or Windows XP.
e Windows Server 2012R2, Windows Server 2012, Windows Server 2008 or Windows Server 2003.

3.2 Network Connectivity

The QX and PC running Auto Dialer should be visible to each other. Note: If Auto Dialer is connected to the QX
via WAN interface, ensure a filtering rule is enabled on the QX firewall for the PC. Auto Dialer will use port 4849.
Creating a call control access rule is not required if the firewall on the QX is disabled or set to Low. For more
information regarding the Filtering Rules, see the Manual-Il: Administration Guide for QX IP PBXs.

3.3 Firmware Requirements

Auto Dialer is compatible with the following Epygi IP PBXs, running the firmware:

Note: Always use the latest available firmware to achieve maximum compatibility with the IP PBX's features and

settings.

Revision 1.1

IP PBX Model Firmware Version
QX500 6.1.45 and higher
QX50/QX200 6.0.2 and higher
QXISDN4+ 6.0.11 and higher
QX2000 6.0.2 and higher
QX1000 5.2.7 and higher
QuadroM32x 5.2.46 and higher
QuadroM8L/26x/12Li/26xi 5.2.66 and higher
Quadro4Li 5.2.46 and higher
Quadro6L 5.2.46 and higher
Quadro4l/2x2 5.2.46 and higher
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4 |nstallation

To install the Auto Dialer, run the executable file and follow the instructions of the Auto Dialer Setup wizard.
Note: Ensure no previous version of Auto Dialer is running before installing a new one.

Later you can launch Auto Dialer by running its executable file "Epygi AutoDialer.exe" which is by default
installed in the C:\Program Files (x86)\Epygi Technologies\ Epygi AutoDialer.

To upgrade from an existing version, close the Auto Dialer application and run the setup file for the new version.
The configuration and the data will be kept after the upgrade. It is not necessary to uninstall the previous
version before performing the upgrade.

5 Auto Dialer Licensing

Auto Dialer is a licensable feature. The Auto Dialer activation license key should be purchased and installed to
make the Auto Dialer functional with the QX. There is no limitation on the number of Auto Dialer applications
connected to the QX at any point in time except for the maximum number of concurrent calls originated by all
connected Auto Dialer applications. It cannot exceed the total number specified in the Auto Dialer expansion
license key installed on the QX. TIP: Auto Dialer does not require the additional 3PCC license to be installed on
the QX.

Install the feature key as follows:

1. Go to the Setup->Licensed Features->Feature page.
2. Click the Add button.

3. Enter the key in the Feature Key text field and Save it. The status of the corresponding feature on the
Features page will change to Reboot needed.

4. Reboot the QX to complete the installation.

Figure 1: Inserting feature key

For more information on Licensable Features, please refer to the Licensable Features on QX IP PBXs guide.
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6 Configuring the QX

Configure an extension on the QX dedicated to Auto Dialer as follows:

1. Go to the Extensions Management page.
2. Select the extension for Auto Dialer and click the "Admin Settings" icon.
3. Go to the General Settings section.
» Insert the Password. TIP: The same Extension Number and Password should be specified in the Auto

Dialer configuration.
» Select Percentage of Total Memory to allocate enough memory space for the extension. TIP: It used

to store the application scenario's voice messages. Before starting calls, Auto Dialer uploads all
needed voice files to the QX.
4. Click Save to apply the settings.

Figure 2: Extension — General Settings section
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7 Configuring Auto Dialer

7.1 Configuring Connection

Once the Auto Dialer extension is configured on the QX, you may start with Auto Dialer configuration. Each time
the Auto Dialer starts, it opens the Options window. In the Connection tab the parameters must be configured
to connect to QX. The same window can be opened after the Auto Dialer starts by selecting the Tools>Options
menu item or corresponding icon in the toolbar.

Connect to

The parameters in the Connection tab are as follows:

e Host — IP address or host name of the QX the Auto Dialer
extension is located.

e Port - listening port on QX for 3PCC interface. The port is set to
4849.

e UserName — the selected extension number on the QX. Calls will
be made on behalf of this extension.

e Password — extension password. TIP: UserName and Password
authentication parameters are used for the registration to the
QX. They must be identical on both QX and Auto Dialer.

e Secure Connection — enables a secure SSL encrypted
connection between the Auto Dialer and the QX. TIP: This option
should be selected when the secure connection is enabled on
the QX (Telephony-> Advanced->3PCC Settings page) to allow
the Auto Dialer connecting to the QX.

Figure 3: Options — Connection tab

Note: You can modify the settings in the Connection tab only when the
Auto Dialer is not connected to QX.
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The Calls tab allows the user to configure the following call-related parameters:

No input timeout — is used to define the timeout Auto Dialer
waits for the called party’s input after playing the voice
menu. If there is no input during that period, the call is
considered to be failed and Auto Dialer will make another
attempt to call the same number.

Max number of simultaneous calls — defines the maximum
number of concurrent calls that the application is allowed
to make. If this number is greater than the total available
with the installed Auto Dialer expansion license key then
the maximum number of the concurrent calls will be limited
to the number available with the expansion license key.

Max retry count — If the call to a particular number fails
because it was busy, not connected (network failure), not
answered or answered without called party’s input (No
input timeout expired), the application will make repetitive
call attempts to that phone number until either:

» The number of failed attempts reached the Max retry

count.

» The call is answered by the called party and the

confirmation input is received.

Time between repeated attempts — defines the interval
between the subsequent call attempts to the same phone
number after the failed attempt.

Figure 4: Options — Calls tab

Schedule start time — defines the time when the calling session will start by the Start by schedule button
command. The application will start the calling session either immediately by the Start command, or at

the scheduled time, when the Start by schedule command is used.

Schedule end time — defines the time when the active calling session will stop after activating the Start
by schedule command. TIP: The calling session will not stop at the scheduled end time if the session

has been activated by the Start command.

Note: You can modify the settings in the Calls tab only when there is no active calling session.
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Date Time

The Date Time tab allows to specify the Date and Time formats for
France and USA to play the "Date" and "Time" messages according
to the selected format.

Note: You can maodify the settings in the Date Time tab only when
there is no active calling session.

Figure 5: Options - Date Time tab

7.2 Configuring the Scenario

Before starting the calling session, you need either create a new calling scenario or open a saved scenario from
a previous calling session. The calling scenario is a sequence of actions executed by the application for every
contact in the calling list.

Creating a New Calling Scenario

To create a new scenario, open the scenario page either by selecting the View->Scenario menu item or
Scenario tab in the toolbar (Figure 6). The scenario may consist of one or more actions. Below are listed the
possible actions:

e callto

e play message
e play date
play time

play number
play menu
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Figure 6: Auto Dialer — Scenario tab

call to

The call to is always the first action in the scenario. Each S0

scenario allows one call to action only. The call to action will tell

the QX to make a call to the phone number retrieved from the

current position (line) in the calling list. Action - Action Input

All phone numbers should be stored in the same column from ; = Name

the calling list. This column should have the header name that

will be selected from the Action Input field next to the call to Reeonse

action. %

Figure 7: Scenario — "call to" action

play message

This action is used for playing a prerecorded voice message to the called party when the call is answered. The
name of the voice message file should always start with the "dial " prefix, otherwise the file will be rejected by
the application. Press the empty cell from the "Action Input" column (next to “play message") to open the file
chooser window and browse for the file.
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Figure 8: Scenario — "play message" action

During the play message action, when the voice message is being played to the called party, the Auto Dialer will
ignore the DTMF tones generated as an input by the called party. If the play message action is the only action in
the scenario that is listed after the call to action, then the call will be disconnected after playing the voice
message.

play date

The play date action is used for playing an automatically - Scenario

generated voice message to the called party with the date

and day of the week. All dates should be stored in the same Action Action Input

column from the calling list. This column should have a call to Phones

header name that will be selected from the Action Input field play message | dial Dr Greetingwav

next to the play date action. ; Py e e D0
Cr— |t
Time
Response |i|

Figure 9: Scenario — "play date" action
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play time

The play time action is used for playing an automatically
generated voice message to the called party with the time of
day. All times should be stored in the same column from the

Scenario

. . . . . Action Action Input
calling list. This column should have a heading name that will T E.,mes
be automatically pulled from the Action Input field next to the play message | dial Dr Greetina wav
play time action. play date Date
3 play time Time
* Name T
Phones
Date £
Response

Figure 10: Scenario — "play time" action

play number
The play number action is used for playing an automatically Scenario
generated voice message representing a number to the called — e ——
party. All numbers should be stored in the same column from i —
the calling list. This column should have a headier name that play message | dial DrGreetinawav
will be selected from the Action Input field next to the play F"IaY date Cale
play time Time

number. . 3 play number Number T
The play number action can be used to play a message to the |« Phones ~ Pl
called party when numbers are required. For example, a Time
message that says, "Your ticket number is, 123456". R —

Figure 11: Scenario — "play number" action
play menu

The play menu action executes in two steps. At first, the prerecorded message will be played to the called party
requesting the person to respond by pressing a digit(key) on their phone. The Auto Dialer will then wait for the
person to enter their response.

The name of the voice message file should start with the "dial " prefix, otherwise the file will be rejected by the
application. Press the empty cell from the "Action Input" column (next to "play menu") to open the file chooser
window and browse for the file.

The valid user inputs and actions of the play menu action are configured in the Menu window which opens
when the user selects the play menu action (Figure 12).
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~  Scenario ~ Menu

Play menu message 1 3: times until the user input or timeout

Action Action Input User Response Response Connect
e Status P p
call to Input Text Column To
play message dial_welcome wav 1 confirmed  |Yes Response
4 dial_invite wav ] | 2 canceled |No Response
play date Date 3 | transfered | Transfered Response [110
play time Time ‘}l HE -l
play message dial_Thank You.wav
* I

Figure 12: Scenario — "play menu" action

Each item (line) of the Menu defines the final action that will be performed in response to called party’s input.

e User Input — defines the called party’s input; the possible options are DTMF digits 0, 1, 2, ... 9, * and #.
The user can enter the DTMF digits at any point when a message is being played.

e Status — defines the status of the call after the called party’s input. The possible options are:

» confirmed — is used to get a "positive" answer from the called person.

» canceled - is used to get a "negative" answer from the called person.

» transferred - is used to transfer the call to PBX extension (auto attendant or user extension) or any
external number.

o Response Text — specifies the text to be written into a column of the calling list after the user’s input.
Response Column — specifies the column heading of the calling list where the above-mentioned text will
be written.

The "Play menu message [n] times until the user input or timeout" option is used to define the number of the
message replay. This field is significant if the application will be calling out on a PSTN POTS line using one of
the QX's FXO lines or trunks. As a usage note, it is suggested to keep the very first greeting message that is
played to the called party as short as possible and recorded so that the user can listen to any part of the
message and understand the intent. Calls placed on the FXO port do not receive answer supervision from the
Central Office so the QX cannot start the message from the beginning when the caller actually answers and
says, "Hello". Depending on when the called party answers, the first part of the message may have already
been played. Therefore, with this option, the application can be configured to repeat this message so that it can
be heard in its entirety.

Opening the Existing Calling Scenario

The created scenario can be saved by selecting the File>Save or Save As menu command or with the
corresponding icon on the toolbar. When saving a scenario, the Scenario tab needs to be visible in the Auto
Dialer’'s window. The scenario file will be saved in the (*.xml) format.

To open the existing scenario, select File->Open->Scenario or click the corresponding icon on the toolbar. The
opened scenario can be modified and saved for future usage.
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7.3 Building the Calling List

The Calling List is used to display the called party's name, phone number, Date/Time as well as show real time
information about the call state, call status and call attempts.

The Calling List can be created either manually or imported from the file.

To create a calling list manually

Right-click on the column header name.
Insert new column.
Enter the new column name and click Save.

o

Fill in the information for each row (name, phone number, date/time, etc.).

To create a calling list by imported file

Use any text editor.

Insert column heading names, separate each column header by comma.
Add a line break after column row.

Separate each component of a certain contact by comma.

Add a line break after each inserted contact.

Save the file in the (*.csv) format.

L A

Note:

> The imported file may have any number of columns but only a few of them are required for use by
Auto Dialer. The main mandatory column is the column containing the phone numbers.

» The QX handles the calls initiated by Auto Dialer. Therefore, the phone number(s) dialed by Auto Dialer
should match the call routing rules specified on the QX’s Call Routing Table.

» Any header name can be used for the "phone number" column and the same name will be presented
in the call to action when creating the scenario.

» If the scenario includes the play date and play time actions, the corresponding columns are also
required in the calling list. Any header name may be used.

» If the scenario includes a menu that uses the Response text then there will need to be appropriate
columns in the calling list and the names of those columns should be specified in the Response
column fields of the menu options.

» The calling list may also include optional fields that are not utilized by the Auto Dialer but are good to
have for user friendliness. For example, includes the "First Name" column containing the names of the
called parties.

There are also some auxiliary columns in the calling list that are being created by the application. The names of
these columns have the " " prefix to distinguish them from the columns created by user. When saving the

calling list, those auxiliary columns will be saved along with the data stored in the columns. These auxiliary
columns will be blank initially and updated as the Auto Dialer runs. The following auxiliary columns are available:

e (CallState — is used for tracking the call state in real time. The last state of the call stays in the calling list
after the call is finished.

e  Status — is used for registering the status of the call after the called party’s input. The possible options
are: "confirmed", "canceled" and "transferred". The values in this column are used by the application to
make a decision about the necessity of making another call to a particular phone number. More
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specifically, if the value of this column for some phone number (calling list entry) is "cancelled", then the
application may consider making another call attempt to that number. In case of "transferred", the
application will transfer the call to the number mentioned in the scenario. In case of "confirmed”, the
application will not make another attempt to call that phone number.

o Attempts — keeps track of the number of call attempts to a specific phone number. Each time the call
is canceled by the called party or fails for another reason, the application will increase the number of
attempts. Regardless the value of the "_Status" field, Auto Dialer will stop calling a specific phone
number if the value of " Attempts” field equals "Max retry count”.

¢ DoNotCall — contain checkboxes to disable specific lines of the calling list. If the checkbox in any line is
checked, then the Auto Dialer will not make a call to the phone number in that line when passing
through the list.

Note: Al fields of the calling list except for auxiliary fields are editable for the user in real time (during active
calling session).

8 Making Calls

Before starting the calling session, you must configure the following items for the Auto Dialer:
e The connection and call-related parameters in the Options window.

e (alling scenario — this specifies the application’s actions to be taken before and after the called party
has entered their response on the phone’s keypad.

o Calling list — a list of phone numbers to call along with the corresponding supplementary information (like
day of the week, time, etc.) to be used by the application for automatic generation of voice messages to
be played to the called party.

Note: For the time of configuring the calling scenario, all voice messages and voice menus need to be
prerecorded and placed in the same folder, accessible for Auto Dialer.

After successful configuration, you can start making calls to the numbers of the Call List. To start the Auto Dialer
(calling) session the following options are available:

e Selecting the Dial>Start menu command or corresponding button on the toolbar.
e Selecting the Dial>Restart menu command or corresponding button on the toolbar.
e Selecting the Dial>Start by schedule menu command or corresponding button on the toolbar.

Start

If the Start is the first command after the application's launch, it will start making calls from the top of the calling
list to the bottom until reaches the last item on the list. During that process, the application populates the
response and the auxiliary columns with the values indicating the user response, state and status of the call and
the number of call attempts to the called number. When the first pass through the calling list is finished, the
application starts the second pass again from the top of the list.

The application will then only call numbers having the "canceled" or "failed" status. If the calling process is not
stopped by the user, the Auto Dialer will repeat the process until the list is completed. At this point, none of the
entries in the calling list will have a status of "canceled" or "failed" or the call attempt values will be equal to Max
retry count.
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The Stop command during the active session will stop the calling process and the current state of the Auto
Dialer will be saved so that with the next Start command, the Auto Dialer will continue calling from the state
where it had been interrupted the previous time.

Note: If the Start is the first command executed after the application's launch, and the user response and
auxiliary fields of the opened calling list are already populated by some values stored from previous sessions,
then the Start will take into account those values without resetting them.

Restart
The Restart command acts similar to the Start command only with a difference: before making calls it will reset

the calling list, cleaning up the user response and auxiliary columns and starting the calling process from the
beginning of the list.

Start by schedule

The Start by schedule command, similar to the Restart command, cleans up the user response and the auxiliary
columns of the calling list and starts calling from the beginning of the list at the point of time specified in the
Schedule start time parameter. The calling session initiated by this command stops at the Schedule end time
parameter unless the calling list is completed before that.

Note: If the calling session initiated by the Start by schedule command has been interrupted by the Stop
command, the calling session will be stopped, no matter what time is specified in the Schedule end time
parameter.

Stop Command

The Stop command stops the calling session, saving the current state of the calling list and current position of
the dialer in the list.
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9 Example — Doctor Office

The below described scenario is one of the usage scenarios of Auto Dialer. All needed materials (scenario file,
audio messages and calling list) can be downloaded from support.epygi.com.

Scenario Description

In this scenario, the Auto Dialer will be used to contact patients to confirm their upcoming appointments. Prior
to calling, the contact list needs to be updated with the patient’s name, phone number and the appointment
date and time. When the Auto Dialer is started, it will begin placing calls to each of the patients. When the call is
answered, the patient will confirm he/she is the correct person. The application will play the date and time for
the appointment and the patient will be prompted to enter one of three options:

e Confirm the appointment.
o (Cancel the appointment.
o Transfer the call and speak to the receptionist (e.g. to reschedule the appointment).

Scenario Summary

Dr. Scenario to Confirm an Appointment

Aetion | Instructions Instructions taken from Calling List Colum: | Columun(s) Updated ' Input Menu
MAIN MENU:
Call |Diel cantzcts from Calling List (fle- Drs Patient List] Phanes
Automatedilsg.wav HI This is an autometed message. Press 1 fyou are Customer
Play Meny 2 patient of Or Whte. Press 2 f you are ot Input Optians #!
Play Message |Dr Greeting.wav: We are callng o confin your appaintment on:
Play Date  |Play date from Callng List Date
Play Tme Py time from Callng List Time
Or Menu Options.wav: To confrm your appointment, please prass opfion 1:
To cancel your appointment press 2 To speak to & receptionist orfo Customer
Play Menyeschedule vour anpoinimen. clease press agton 3 Input Opions #2

Play Message |Thank You.wav: Thank you, and have a qood day!

Customer Input Options #

1 Corect parson Status = Confirmed & Response = Comect person

J Wrang person Status = Canceled & Responsz = Wrong persan
Customer Input Options 2

1 Appaintmen corfimed Status = Confimed & Respanse = Confmed Appt.

2 Appaintment canceled Status = Confimed & Respansz = Cancaled Appt

1 Transfer o 2 Recaptionis Stetus = Transferred & Response = Transfened

Figure 13: Doctor Office - Scenario summary
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Audio messages

The following audio messages will be used:

o AutomatedMsg — Hil This is an automated message. Press 1 if you are a patient of Dr White. Press 2 if

you are not.
e Dr Greeting — We are calling to confirm your appointment on:

Dr Menu Options — To confirm your appointment, please press option 1: To cancel your appointment
press 2: To speak to a receptionist or to reschedule your appointment, please press option 3.

o Thank You — Thank you, and have a good day!

Scenario Configuration

Figure 14: Auto Dialer scenario
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Calling List

The calling list is created by the imported (*.csv) file.

Mame Phones Date Time Response
Andy 997725551212 4/10/2017 11:00 AM
Jim 992125551300 4/11/2017 12:00 PM
Bob 997725551005 4/14/2017 1:00 PM
Susan 940725551219 4/7/2017 2:00 PM
Rolando 921425551850 4/12/2017 10:00 AM
Jane 921475551320 4/14/2017 4:30 PM
David 930525551140 4/18/2017 5:45PM
Ciara 921605551435 4/19/2017 6:00 PM

Figure 15: Calling List
Results

After running the application, the following results have been collected:

e Andy - answered the call and confirmed the appointment.

e Jim — the call was not for him.

e Bob — pressed option 3 to transfer to the receptionist.

e Susan - the call might have gone to voicemail since the call was answered but they never confirmed
any option.

e Rolando - the call did not complete.

e Jane — answered the call and confirmed the appointment.

e David — answered the call and canceled the appointment.

e Ciara — pressed option 3 to transfer to the receptionist.

Figure 16: Calling List — Results
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10 References

Refer to the below listed recourses to get more details about the configurations described in this guide:

e Manual-Il: Administration Guide for QX IP PBXs
e Manual-Il: Administration Guide for Quadro IP PBXs
e Licensable Features on QX IP PBXs

Find the above listed documents on Epyai Support Portal.

THIS DOCUMENT IS PROVIDED TO YOU FOR INFORMATIONAL PURPOSES ONLY. The information furnished
in this document, believed by Epygi Technologies to be accurate as of the date of publication, is subject to change
without notice. Epygi Technologies assumes no responsibility for any errors or omissions in this document and
shall have no obligation to you as a result of having made this document available to you or based upon the
information it contains.

Epygi is a registered trademark of Epygi Technologies, Ltd. All other products and services are the registered
trademarks of their respective holders.
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